ブロギングライフ

ブログサイト運営関連、AdSenseについての情報などを発信しています。

関連コンテンツで画像が表示されない場合の対処法

関連コンテンツで画像が表示されない場合の対処法

AdSense 関連コンテンツが利用できるようになったが、サムネール画像が表示されず、テキストのみの形式になってしまう場合があります。この様な現象が発生した事例について、AdSense ヘルプフォーラムの投稿でもこれまでに何度か見ています。私の運営するサイトでは、過去に二度、関連コンテンツでサムネイル画像が表示されない状況になったことがありました。これまでの経験などを含めて、関連コンテンツで画像が表示されない場合の事例・理由と対処法について紹介します。

関連コンテンツで画像が表示されない場合の理由と対処法

AdSense ヘルプの関連コンテンツ機能について のページには、重要なポイントの項目の中で、ほとんどの記事で画像を使用していないサイトの場合、関連コンテンツ ユニットはテキストのみの形式で表示されます。と記載されています。

各記事にOpen Graph タグで画像を指定する

過去のAdSenseのヘルプの説明では、関連コンテンツを利用するためには各記事にユニークな(各記事に固有の)画像が含まれることが推奨されていました。昨年、運営する二つ目のサイトで関連コンテンツが使用可能になった時、サイトに関連コンテンツユニットを設置したところ、画像がないテキストのみの表示となりました。

そのサイトでは、ほぼ全ての記事それぞれにユニークな画像を使用していました。AdSense サポートに問い合わせたところ、担当の方から関連コンテンツに画像が表示されるための条件として、サイト内に1000以上のユニークな画像があることが条件となっているかもしれないと返事を頂きました。

備考 / 注意事項:
サイト内に1000以上のユニークな画像があることが条件は、関連コンテンツの利用基準が大幅に緩和される前(2016年)の話です。

各記事でユニークな画像は使われており、トータルでは1000位はあるのではないかと思っていましたが、ギリギリで足りないかもしれない可能性も考えられたため、サイト上の全画像数がどれ位あるか大まかなところを把握しようと思い、記事を一通り見直しました。その時に、古い記事にはアイキャッチ画像が設定されていないことに気づきました。アイキャッチ画像が設定されていないと、OGPの画像指定のタグも出力されません。関連コンテンツのヘルプには、より適切な記事を推奨するためにOpen Graphを使用することを推奨しています。

関連コンテンツで画像が表示されないのは、Open Graphのタグで画像が指定されていないことが原因ではないかと考え、アイキャッチ画像が指定されていない古い記事一つ一つを設定していったところ、関連コンテンツで画像が表示されるようになりました。

トップドメイン上の全てのページが対象となる

関連コンテンツで表示されるおすすめコンテンツは、トップレベルドメイン全体のコンテンツが対象となります。サブドメインやサブディレクトリに画像が含まれていないページが多く存在していると、関連コンテンツでは画像なしテキストのみとなる可能性が高いです。

追記:
関連コンテンツの表示制御設定を利用すると、サブドメインなどを表示対象から除外することができます。2017年12月から表示制御を導入して、再びテキスト中心のコンテンツがあるサイト、ブロギングライフBBをサブドメインに戻して運用しています。

本サイト、ブロギングライフは9月に入ってから関連コンテンツが利用できるようになりました。直ぐに関連コンテンツユニットを設置したところ、テキストのみの表示でした。

関連コンテンツのおすすめが画像なしテキストのみで表示される

備考:
上の画像でグリーンのスクリーンがかかっているのは、Chromeの拡張機能Publisher Toolbarによる広告オーバーレイです。広告オーバーレイが有効になるとサイト運営者が広告をクリックしても、収益が発生しません。Publisher Toolbarは、誤クリックの防止や広告情報の取得や設定などができる便利な機能を備えています。

ブロギングライフ(本サイト)で当初、関連コンテンツがテキストのみ表示された理由は、サブドメインに立ち上げ中のフォーラムサイトがあったためです。フォーラムサイトの記事の多くは画像が使用されていません。関連コンテンツに表示されるおすすめはサブドメインのフォーラムのページも表示されていました。

フォーラムプラットフォームはOpen GraphやSchemaのスニペットには基本的に対応していません。フォーラムの記事でも画像をタグで指定できないかなどについて検討しましたが、現実的に対応は難しいため、サブドメインにあったフォーラムを独自ドメインに引っ越すことにしました。

サブドメインのフォーラムサイトを引っ越し後、三日目におすすめ記事(コンテンツ)が表示されなくなりました。以前、メインのサイトでメニューを作り直し、カテゴリー構成を大きく変更した時に発生した関連コンテンツでおすすめが表示されない状態とほぼ同じ現象が起きました。フォーラムサイトを引っ越したことにより、トップドメイン上の一部コンテンツがなくなった(サブドメイン上のサイトがなくなった)ことによるものと推測しています。

おすすめコンテンツが表示されない状態になっている間も、固定ページ等で画像の指定をしていないものや、画像を使用していないページなどを探して、基本的にほとんどのページで画像をOpen Graphに指定するように見直しを行いました。

前回、関連コンテンツのおすすめが表示されない問題は、二ヶ月半程度してから表示されるようになりましたが、今回は幸いなことに翌日には無事、画像も表示されるようになりました。

これらの経験から、関連コンテンツでサムネイル画像が表示されず、テキストのみが表示される場合は、サイト上のほとんどのページにOpen Graph (または、Schema)のタグで画像を指定する対策を取ることをお勧め致します。

コメントを残す(承認後表示されます)

*
*
* (公開されません)

Return Top
error: Content is protected !!